Jump to content
WI BIMMERS - Wisconsin's BMW Community
DrLeadFoot

Chapter GMW | E30 LS1 (starting on post #1427)

Recommended Posts

16 hours ago, straight6pwr said:

10 to 1 odds he couldnt get the locking strip to lock into the channel. its really a pain in the ass, even with the correct tool.

This!  I did not have the right tool.  Holy hell it was a pain! If I used the original gasket it would have been a lot easier. 

On 9/5/2019 at 5:06 PM, Jdesign said:

What was the issue? Also I never noticed until now that you have an M3 antenna on your car.

Previous owner did an antenna delete and popped the M3 one on.  Love the look!

Share this post


Link to post
Share on other sites
On 9/7/2019 at 7:36 AM, DrLeadFoot said:

This!  I did not have the right tool.  Holy hell it was a pain! If I used the original gasket it would have been a lot easier. 

Previous owner did an antenna delete and popped the M3 one on.  Love the look!

Nice, I like it too! I always was a fan of the Fuba style antennas

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.